Welcome to Help center

We are here to help

Call to undefined method DateTime::createFromFormat()

Follow

Need to update PHP version on server to PHP 5.3+

Comments

  • Avatar
    Fernando Zorrilla

    Several suggestions (from an user who bought the plugin):

    • Plugin should warn about PHP version without giving error. Think about it is little weird to buy a plugin and find out free version works better than paid one...(at least error free)

    -Even more important , Pro version should warn in the sell page it will work only with PHP>5.3 . I read http://codecanyon.net/item/maintenance-pro-wordpress-plugin/2781350 but it doesn't warn about this. (Or i couldn't find it)

    And this is very weird. Free version works with PHP <5.3 and paid version doesn't.

    -I'd recommend replacement for createFromFormat so Pro version works with any PHP Version. Ok, more weirdness: error is on the free part of the plugin when the user activates de Pro part.

    And a suggestion aside the plugin:

    -Creation for password on this support site should warn in a proactive way how the password is required instead after. A new user rarely will know in advance how the password should be constructed...

    Thank you

  • Avatar
    Ilya Pavlov

    Fernando,

    Thanks for review and suggestions, we will implement changes in new plugin version.

  • Avatar
    Fernando Zorrilla

    Alright I was able to upgrade to PHP 5.3 and everything went just fine!

    However being a plugin developer myself, I strongly suggest that plugin detect PHP min version to run properly.

    Thank you!

  • Avatar
    Ilya Pavlov

    Fernando,

    We rebuild some functions and now plugin support version PHP 5.2

  • Avatar
    Fernando Zorrilla

    Great, I've been using your plugin a lot(!!!!)
    Thanks for your work.
    Best Regards
    Fernando

Top
Powered by Zendesk